Thursday, October 17, 2013

More on Accuity + Quarq


After spending a few nights dealing with the required decoupling math for the Quarq + Accuity unit I’m still not 100% there. I feel I’m 95% there, but something is eluding me.

The right measurement is dead on, within 1-3% of the Quarq.

The left measurement is another story ranging from 5 – 8% out.

What I thought was the original issue was due to the non-integrated spider and that I didn’t place the shear strain gauge deep enough down the hole. As a result it can see some of the stain caused by the torque on the right arm in the left sensor. A few ways of dealing with this:

  • Reinstrument with another strain gauge (about 3 evenings of work)
  • De-coupling Math (in theory short, but probably 3 evenings of work… to get right)

Essentially the math works by calculating the torque on right arm from the right strain sensor setup, and then subtracting that small percentage from the left arm. How much are we talking?

For every 1 N-M on the right arm, I can see 0.0075 N-M on the left arm. I messed up the math earlier which caused each arm to work nicely independently but together they didn’t work right which resulted in a significantly reduced measurement of power and the balance skewed 100% right.

Now that this is all sorted I have the problem that the Left sensor is reading low, both independently and concurrently. I can artificially dial it into the Quarq but I don’t believe that is the correct thing to do.

Question I’m trying to determine. Could the loss of torque due to the bottom bracket bearings be affecting the calibration? Would the Quarq have been calibrated for each side and then averaged? Am I missing something?

I was checking for force sensitivity due to twisting the arm and at best I could muster was adding more force, not losing it.

Other things of note

The small Sunnto style m-ANT (tiny) stick DOES NOT WORK with the old .NET libraries. You need the latest ones! Having realized that I’ve started using my double powermeter recording software with an AP1 or AP2 usb stick. I dislike how it sticks out on my laptop though. I think I just need to replace a .DLL file but haven’t tried it.

To summarize:

  • Carbon fibre remaining linear; multiple calibrations resulted in nearly the same numbers (18.62 versus 18.82 bits/N-M) with multiple points.
  • There is some permanent strain in the carbon caused somewhere between flying it from ON to AB. Didn’t affect calibration really.
  • Bad decoupling math was the problem with it not functioning correctly in AB and resulted in swapping to my Aluminum Rival Crank which still works very well.
  • Still investigating the small percentage difference between prototype and Quarq
  • m-ANT stick requires new libraries for .NET development
  • Samsung commits to ANT+; At least on flagship
  • If you have an idea on why my calibration might be off write me here

Personal notes: I wish that the Nexus 5 will be reasonably priced and have ANT+.


  1. Hi Keith, I'm interested in the software you're using. Reason is that I want to capture the ANT+ data stream from by Powertap G3 (in real time) and display on a computer monitor. Is this possible with your software? If so is there any way I can get a copy (to run under Win 8 ideally). Regards, Frank

    1. Yes. It's something I coded up a while ago. It's coded in .NET C#. It was tested in WinXP and Win 7. I found out it doesn't work with the m-ANT tiny ANT+ sticks but I think I just need to update the DLL files. Email me at or maybe I can post it up. It's quite buggy though. Easy to crash. Trainer Road is an option potentially, but maybe not what you want.

  2. has free software that will do this